28/07/2014

ad.

Como evitar a divisão por zero (#DIV/0!) no Excel

Se você está fazendo alguma operação com colunas ou linhas no excel e falta um valor em alguma célula, o sistema mostra algumas mensagens de erro que enfeiam qualquer planilha, como #DIV/0! ou #ERR!

Uma forma fácil de se livrar delas é colocar um condicional (comando SE) na fórmula. No exemplo abaixo quero dividir a primeira coluna pela segunda. Como não possuo todos os valores do divisor, fiz um pequeno comando informando à planilha que se o valor não existir ou for zero, o resultado deve ser zero. Claro que mais correto seria colocar um espaço em branco.

Para isso, basta selecionar o célula e digitar a fórmula abaixo:

=SE(C4;B4/C4;0)

Distrinchando:
SE(condição; valor se verdadeiro; valor se falso)
O comando SE verifica se a “condição” é verdadeira, no caso se há um valor na célula C4. Se for verdadeiro, há um valor, realiza a divisão B4/C4; se for falso, devolve zero.

Na imagem abaixo, a primeira célula apontada pela seta possui a fórmula acima e mostra zero. Já a célula apontada pela seta de baixo possui apenas uma divisão comum (=B7/C7) e dá erro.

Excel - divisão por zero na fórmula

Excel - divisão por zero na fórmula

Se quiser colocar um espaço em branco, altere a fórmula para =SE(C4;B4/C4;”)

Pode-se trocar a divisão (B4/C4) por qualquer outra operação válida. Alguns exemplos: B4*C4; ln(C4), B4^C4, … e tudo o mais que a sua necessidade mandar.

comentários

19 comentários para “Como evitar a divisão por zero (#DIV/0!) no Excel”

  1. Osman em 06/11/2008

    Da forma que vc fez fica muito simples, compliquei um pouco mas o resultado é o mesmo.

    Ficou assim – A1 tem o valor de erro qualquer, incluir o numero 0 na A2, na B1 coloque =ÉERROS(A1), na C1 inclua =B1+1, na D1 coloque =ÍNDICE(A1:A2;C1;1)

    EXP1
    =CEL =ÉERROS VERDADEIRO+1 INDICE

    #DIV/0! VERDADEIRO 2 0
    0

    EXP2
    10 VERDADEIRO 2 10
    0

  2. Marcio em 11/07/2009

    Muito boa dica é o que eu precisava,valeu mesmo.

  3. João Ramos em 28/11/2009

    Excelente simplificação. Foi imensamente util.

  4. Alexsandro Santana em 29/12/2009

    Ótima Dica Companheiro!!
    Obrigado!!

  5. José Augusto em 18/03/2010

    Dica perfeita brother!!!

    Thank you very much!

  6. Humberto em 23/08/2010

    Desta forma que vc fez fica facílimo, resolvi um monte de bronca com esse tipo de erro, muito valorosa sua dica.
    Obrigado

  7. Isabella em 25/11/2010

    Adorei ;)

  8. Juceley Miguel em 24/05/2011

    Excelente dica. Me ajudou muito. Essas dicas nos ajudam muito.

  9. Rober em 08/08/2011

    Obrigado pela dica!!!

  10. luanna em 10/04/2012

    eu amei a dica obrigada

  11. luanna em 10/04/2012

    Obrigadaaaaaaaaaa!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

  12. Rodrigo em 11/05/2012

    Deu certo ! Obrigado !!!

  13. Marcelo em 16/05/2012

    Salvou minha humilde panilha de custos aqui rsrsrsr…. Não sou expert em excel mas sempre estou usando esta ferramenta pra calcular e lançar dados para tornar minha vida um pouco mais facil dispensando em quase 100% o velho e bom papel; Estava com o mesmo erro do post e a solução veio na hora certa (só fiz uma pequena adaptação aos meu calculos), muito obrigado!

  14. FISCHER em 16/05/2012

    fantastico – obrigado . . .

  15. Jesus Baccaro em 25/05/2012

    Valeu!

    Salvou o dia!!!

    Obrigadúúú!!!!

  16. Vicente Maia em 29/05/2012

    Vlw…Foi de grande ajuda. Funcionou direitinho…Só que no lugar de ponto e vírgula, entrou vírgula.

  17. João Niny em 06/09/2012

    Funcionou em parte.
    Se o resultado se baseia numa célula com valor real tudo bem, mas se o resultado se baseia numa célula vazia proveniente duma PROCV não consigo evitar #valor.
    Ex:
    Imagine uma célula I4 que tem esta fórmula: =SE.ERRO(PROCV(A4;’CM ADVGEN’!$A$2:$D$289;3;0);”") e que dá um resultado sem valor.
    Quando na célula adjacente J4 tento fazer um cálculo de percentagem usando a sua sugestão: =SE(I4;(D4-I4)/I4;”") para evitar #valor, não funciona….. ele aparece na mesma.

    Se existir um resultado numérico real na célula I4, aí a fórmula do cálculo de percentagem funciona perfeitamente.

    Consegue explicar-me o erro que estou a cometer?
    Cump João Niny

  18. sergio Valentini em 24/09/2012

    Valeu, ajudou muito. Nada como perguntar para quem entende! Parabéns e muito Grato!

  19. Alexandre em 10/06/2013

    Ajudou, GRATO!

Deixe seu comentário