25/04/2014

ad.

OpenOffice: como importar uma planilha para um documento de texto

Recebi um pedido sobre como importar uma planilha do Calc para dentro de um documento do Writer e mantê-la como planilha, não como um documento de texto. E uma boa pergunta e, felizmente, a resposta é muito simples.

Primeiro vamos criar uma planilha. Inicie o Calc e crie ou abra uma planilha já existente. No exemplo abaixo eu fiz uma com os 15 primeiros dias de 2009 na bolsa de valores.

openoffice_bolsa_jan_2009

Em seguida selecione TODAS as células que deseja copiar e digite Ctrl-c.
Feito isso, abra ou crie um documento de texto no Writer e vá ao menu Editar > Colar Especial (ou Ctrl-Shift-C). Na caixa de diálogo que se abriu, selecione o modo de importação, no caso da minha versão e calc8, mas a sua pode ser qualquer outra, desde que seja uma “Calc” (nome do aplicativo de planilha do OpenOffice) está tudo certo.

openoffice-colarespecial1

Surgirá no seu documento uma “imagem” da planilha perfeitamente formatada. Mas se você clicar nela perceberá que não é possível editar. Para alterar os dados basta dar um duploclique que abrirá como planilha, exatamente como mostram as figuras abaixo.

planilha no writer:
openoffice-planilha-no-writer

Editando a planilha no writer (após o duplo clique):
openoffice-editar-planilha-no-writer

Simples, não?

Como evitar a divisão por zero (#DIV/0!) no Excel

Se você está fazendo alguma operação com colunas ou linhas no excel e falta um valor em alguma célula, o sistema mostra algumas mensagens de erro que enfeiam qualquer planilha, como #DIV/0! ou #ERR!

Uma forma fácil de se livrar delas é colocar um condicional (comando SE) na fórmula. No exemplo abaixo quero dividir a primeira coluna pela segunda. Como não possuo todos os valores do divisor, fiz um pequeno comando informando à planilha que se o valor não existir ou for zero, o resultado deve ser zero. Claro que mais correto seria colocar um espaço em branco.

Para isso, basta selecionar o célula e digitar a fórmula abaixo:

=SE(C4;B4/C4;0)

Distrinchando:
SE(condição; valor se verdadeiro; valor se falso)
O comando SE verifica se a “condição” é verdadeira, no caso se há um valor na célula C4. Se for verdadeiro, há um valor, realiza a divisão B4/C4; se for falso, devolve zero.

Na imagem abaixo, a primeira célula apontada pela seta possui a fórmula acima e mostra zero. Já a célula apontada pela seta de baixo possui apenas uma divisão comum (=B7/C7) e dá erro.

Excel - divisão por zero na fórmula

Excel - divisão por zero na fórmula

Se quiser colocar um espaço em branco, altere a fórmula para =SE(C4;B4/C4;”)

Pode-se trocar a divisão (B4/C4) por qualquer outra operação válida. Alguns exemplos: B4*C4; ln(C4), B4^C4, … e tudo o mais que a sua necessidade mandar.

Planilha do OpenOffice: como arrastar uma célula sem criar uma série

Na maioria das planilhas, se você clicar e segurar no canto inferior direito de uma célula, desde que possua algum valor, e arrastar, ela criará uma série. No OpenOffice, por exemplo, se tiver um número e arrastar as próximas células serão incrementadas por 1, como na imagem abaixo. Ainda, se digitar “segunda-feira” em uma célula e arrastar, as próximas serão automaticamente preenchidas com os dias da semana: terça-feira, quarta-feira, etc…

Mas se você não quiser que aumente, basta pressionar a tecla Ctrl enquanto arrasta e o resultado sairá como na figura abaixo, sem o incremento, apenas a cópia.

OpenOffice – Como inserir cálculos em um documento de texto

Uma das coisa que mais impressiona no OpenOffice é a facilidade com que as operações mais rotineiras são feitas. Até pouco tempo, se você quisesse  inserir uma planilha simples em um documento de texto, era obrigado a importar uma ou utilizar macros longas pra isso. Pois bem, com o OpenOffice basta tratar sua tabela como se fosse uma planilha feita no Calc.

Churrascada
Nada melhor que uma boa churrascada pra alivar a tensão, desde que os nervos não aflorem na hora de rachar as depesas. Calma! Em um bom churrasco de nerds, alguém já fez um documento no Writer pra resolver o assunto:

Até aqui tudo bem, mas não seria ótimo se o cálculo da soma fosse feito automaticamente? Pra fazer isso basta clicar na célula que deveria conter a soma e pressionar F2. Abrirá um campo para inserção de uma fórmula, como o da imagem abaixo.

adicionando uma fórmula a uma célula da tabela

adicionando uma fórmula a uma célula da tabela

Nesse campo, vamos colocar “=sum<b2:b4>” (sem as aspas, claro). O sinal de “=” indica que começou uma fórmula, “sum” (soma, em inglês) é a operação que desejo realizar, e “<b2:b4>” indica as células da tabela que entram na somatória. Note que a célula com a palavra “Produto” é A1. A partir dela o número aumento na horizontal e e letra na vertical. Exatamente como em uma planilha. Portanto, a célula de “Valor R$” é a A2, Picanha é B1, “57,00″ é B2, e assim por diante. No nosso caso, queremos somar de “57,00″ (B2) até “30,00″ (B4), logo, o alcance será <b2:b4>. E a seguir vemos como fica a tabela já com a soma.

resultado de um cálcula em uma tabela no writer

resultado de um cálculo em uma tabela no writer

Pronto, agora quando alterar um dos valores da tabela a soma será atualizada automaticamente. Claro que é possível colocar outros cálculos. As funções básicas de uma planilha estão incluidas entre as possibilidades.

OpenOffice – Ovos de Páscoa

Os easter eggs (ovos de páscoa, em inglês), são “brincadeiras” que os programadores deixam dentro dos programas. O OpenOffice, claro também tem as suas. Uma delas envolve a foto de alguns programadores da parte de cálculo da Planilha. Para ver a foto apenas adicione =starcalcteam() em qualquer célula de uma planilha, e aparecerá a seguinte foto: